Skip to main content

Retrieving Data

Profile picture for user digthefalls
Submitted by digthefalls on Tue, 11/14/2017 - 12:06

I have completed my first data collection project. One sensor did not make it through the test sequence...

The second sensor will connect to my Android App, but I cannot retrieve the data via Chrome App. I have tried two different laptops...
Both laptops show "bluetooth adapter unavailable", although the sensor does show in connectable devices in the Bluetooth connection window.

Any advice would be greatly appreciated.

(It is important I retrieve this data as it is the first readings I have been able to make and will directly affect the use of the sensors moving forward.)


Profile picture for user PocketLab


Wed, 11/15/2017 - 18:19

Hi Edward, 

Sounds like a fun day testing at some waterfalls! I'll help you troubleshoot the memory issue so we can get your data. First, what type of laptops are you using? On Android, are you trying to retrieve the data from the native Android App or the PocketLab Web App on a Chrome browser? 

Basically, the memory function is available in two places. Our newly updated iOS app on iPhones and iPads, and our Web App available through a chrome browser on Android, Chromebook, and Macs. The Web App is still not available on Windows devices because we are waiting on an issue from Microsoft. 

Let me know the devices you are trying to connect with and then I can help further. Also, what device did you connect with to set up the memory mode function at the beginning of the test? Are you having issues connecting with that device? 


Profile picture for user digthefalls


Wed, 11/15/2017 - 20:25

Hi Robby,

I am hoping I was able to collect data... period... at this point. 
You are mentioning turning on "memory mode". I am hoping by setting the device to "Record" from the Android device it would have automatically collected the data to memory even when the device was out of range for my phone?

I have tried an older Lenovo T430 (which worked prior to the tests but does not now... I tried to reinstall the app and it says it cannot unzip the file). I also tried on a newer T450s.

I have not tried to connect an iPhone to the device to retrieve any data because I wasn't aware of the functionality.

The day was fun. I have to update the device carrying pod to eliminate the possibility of it getting caught in the eddy of the current. I also had to rescue it from halfway down the waterfall... Some design flaws were only apparent after trying it for the first time.

I realy hope the device(s) collected...

Thank you for the assistance!

Profile picture for user PocketLab


Thu, 11/16/2017 - 23:49

Hi Edward, 

Okay, I understand what happened now. I am sorry for the confusion on how the memory mode works, but the data actually was not recorded. While we eventually would like to have it work in the way you described, the memory currently needs to be "set-up" in memory mode. Memory mode is available on the Web App and the iOS App. You'll see in the top left corner what looks like a memory chip icon. You'll click that to set everything up for the recording, which includes more flexibility with the data rates.

Is the Lenovo a Windows device or Chromebook? We did have a recent bug pop up on the Chromebook native app that would block the download with the can't unzip file message. We've since fixed it, so it should work. The memory mode however is in the web app, which for that you just open a Chrome browser and go to You can also do that through your Android, but in a chrome browser, not the Android app. If you have an iPhone or iPad available to try the native iOS app now has the memory function. 

This video shows how to connect to the PocketLab Web App via a Chromebook. It's the same process for an Android phone or tablet:

And this video shows how to set up the memory mode in the PocketLab Web App:

We are sorry for the confusion. We do eventually want a function where if the PocketLab disconnects, it automatically keeps collecting data at those current settings, but it's not available yet. The firmware involved in something is much more complicated, so it will take a bit of time to develop. 

We are really excited for your use cases and involvement in the PocketLab community. If there is anything else we can do to support you, let me know. 




I do have to admit a certain level of disappointment, especially since we were in contact prior to the purchase to be sure it would fit our needs. I do understand limitations in the product now and will see what I can do moving forward... Right now, we really need a way to capture the data for these locations without having to use an expensive GPS unit (which also would not capture all the other information your sensors gather).

I am still excited to collect data with the devices in the future, but it does not seem this is going to be possible for now (unless I switch to iOS or the web app will load to my PC).

Thank you for the information. I will keep you apprised of any updates to the project.
Please let me know if you have any firmware updates in the future, as the data capture to the phone is not important to me. Capturing to the device and being able to download through a usb would be great!


Profile picture for user PocketLab


Tue, 11/21/2017 - 18:04

Hi Edward, 

I understand your disappointment. We are working as hard as we can to get these features up and running on all platforms. There was an unexpected delay from Microsoft which has caused the issue for Windows. Microsoft is notoriously difficult to work with for Bluetooth development, so this has been disappointing to us as well. We should know more very soon about the status of Windows. 

Do you have an Android phone? The web app works on Android, so you can set up the memory through the web app on an Android device. You would just go through a Chrome browser on the phone instead of opening the PocketLab Android App. We are most likely going to be looking for beta testers for some of our cloudlab features soon, which might help with some of your use cases. Let's see if we can get the memory mode set up on your Android and then I can let you know more about cloudlab, which I think would help with your use case. 

Thanks for your patience!